Fritz!OS-Update 84.06.23 bringt anscheinend Probleme bei der FritzBox-NAS-SMB-Freigabe [Update 05.10.2015]

Heute habe ich das kürzlich erschienene FRITZ!OS-Update 84.06.23 für meine FritzBox 7390 installiert, die bis dahin noch mit FRITZ!OS-Version 84.06.20 lief, und staunte nach der Installation nicht schlecht, als das FritzBox-NAS weder in der Netzwerkumgebung auf meinen Windows-PCs noch auf meinen Medienplayern (Xtreamer SideWinder 3 und FireTV mit Kodi) gefunden wurde. Mit Windows-PCs konnte ich zwar auf das FritzBox-NAS zugreifen, allerdings nicht mit meinen Medienplayern. Diese weigerten sich standhaft eine Verbindung herzustellen. Da sich außer diesem Update auf der FritzBox nichts am Netzwerk verändert hatte, lag die Vermutung nahe, dass das Problem durch das FRITZ!OS-Update zustande gekommen ist.

Sicherheitshalber prüfte ich alle Einstellungen meiner FritzBox, aber da stimmte alles. Am Netzwerk liegt es auch nicht, die Medienplayer erkannten meinen PC und konnte auf die Freigaben zugreifen.

Nach einer kurzen Durchsicht, was das Update für Neuigkeiten bringt, entschied ich mich dafür, vorerst die alte FRITZ!OS-Version 84.06.20 wieder einzuspielen. Zu finden ist diese übrigens auf dem AVM-FTP-Server. Beim Zurückspielen werden die Werkseinstellungen wieder hergestellt, man sollte also vorher eine Sicherung der Einstellungen durchführen. Falls es in Vergessenheit geraten ist, die Werkseinstellung für die IP-Adresse der FritzBox ist 192.168.178.1.

Nach dem Downgrade auf FRITZ!OS-Version 84.06.20 funktioniert der SMB-Zugriff wieder tadellos.

[Update 05.10.2015]: Anscheinend liegt die alte FRITZ!OS-Version 84.06.20 nicht mehr auf dem AVM-FTP-Server. Wer sie benötigt, kann Sie daher auch hier runterladen.

Auf der Suche nach einer Lösung für das Problem, bin ich auch auf diese AVM-Seite gestoßen. Ich weiß, die Seite betrifft die FritzBox-Version für Österreich / Schweiz, mir stellt sich allerdings die Frage, ob die deutsche Version jetzt auch wenigstens teilweise davon betroffen ist. Wie gesagt, unter Windows komme ich durch Eingabe der IP-Adresse ohne Probleme an mein FritzBox-NAS, nur die Windows-Netzwerkumgebung listet das FritzBox-NAS nicht mehr auf und die Medienplayer finden es ebenfalls nicht.

Falls noch jemand das gleiche Problem oder vielleicht sogar eine Lösung dafür hat, würde ich mich über Feedback freuen.

[Update 04.02.2015]: Laut diesem Foreneintrag fehlt nmbd (NetBIOS-Namensauflösung) anscheinend wirklich im FRITZ!OS 84.06.23 (es betrifft also nur die FritzBox 7390). Der für den Sambazugriff nötige smbd (Datei- und Druckerfreigabe) ist aber anscheinend vorhanden. Das erklärt meine oben beschriebenen Erfahrungen.

AVM hat sich mittlerweile auch zu der Problematik geäußert. Leider nicht so eindeutig, wie man das gerne hätte. Einmal wird gesagt, dass das Verhalten in der neuen FRITZ!OS-Version 84.06.23 angeblich so gewollt ist. Ein anderes Mal, ist es nicht gewollt. Na super, hoffentlich war das wirklich nur ein Fehler seitens AVM, der in der nächsten Version wieder korrigiert wird. Leider könnte man diese AVM-Seite auch so deuten, dass dem nicht so ist :-(.

2 Gedanken zu „Fritz!OS-Update 84.06.23 bringt anscheinend Probleme bei der FritzBox-NAS-SMB-Freigabe [Update 05.10.2015]“

  1. Ich kann das bestätigen. Nach Umstellung von 06.20 auf 06.23 gibt es keinen Zugriff mehr auf die NAS-HDD per Kabel (!) von Win7 und XP. Interessanterweise funktioniert der Zugriff per Netzlaufwerk aber von XP-Rechnern aus per WLAN. Probeweise habe ich einen XP-PC per LAN angeschlossen – und siehe da – keine Verbindung. Als nächstes versuche ich Linux-Mint. Leider hat man sich an die funktionierenden Netzlaufwerke gewöhnt… ;-( Der Workaround wird also eine WLAN Verbindung sein, auch wenn es dadurch viel langsamer wird…

    1. Von PCs aus hatte ich auch nach dem Update die Möglichkeit, mich mit dem FritzBox-NAS zu verbinden, allerdings nur durch direktes Ansprechen des Gerätes (über die IP-Adresse). In der Netzwerkumgebung wurde das FritzBox-NAS nicht mehr angezeigt.

      Die nicht vorhandene Anzeige (z.B. in der Netzwerkumgebung) liegt – wie oben beschrieben – daran, dass der nmbd-Dienst fehlt. Dass trotzdem das direkte Ansprechen möglich ist, hängt damit zusammen, dass der smbd-Dienst vorhanden ist.

      Mit dem PC ist das – sagen wir mal – halb so schlimm, mit Geräten, die aber nur über die Suche und den Namen Geräte finden, geht das so natürlich gar nicht :-(.

      Oder meintest Du, dass die Netzwerkumgebung die Geräte per WLAN noch findet? Das wäre seltsam.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.